remote processor messaging (rpmsg) subsystem · Maintained
Maintainers
- M Bjorn Andersson <andersson@kernel.org>
- M Mathieu Poirier <mathieu.poirier@linaro.org>
Paths
- F
Documentation/ABI/testing/sysfs-bus-rpmsg - F
Documentation/staging/rpmsg.rst - F
drivers/rpmsg/ - F
include/linux/rpmsg.h - F
include/linux/rpmsg/ - F
include/uapi/linux/rpmsg.h - F
samples/rpmsg/
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on virtualization (capped at 30), ordered by date desc.
-
STALE118d
[PATCH 07/12] rpmsg: use generic driver_override infrastructure
2026-03-24 · Danilo Krummrich <dakr@kernel.org> -
STALE226d
[RFC PATCH 2/2] rpmsg: virtio_rpmsg_bus: get buffer size from config space
2025-11-14 · Tanmay Shah <hidden> -
STALE226d
[RFC PATCH 1/2] rpmsg: virtio_rpmsg_bus: allow the different vring size for send/recv
2025-11-14 · Tanmay Shah <hidden> -
STALE753d
[PATCH virtio v4 19/19] virtio: rename virtio_find_vqs_info() to virtio_find_vqs()
2024-07-08 · Jiri Pirko <jiri@resnulli.us> -
STALE753d
[PATCH virtio v4 17/19] virtio: convert the rest virtio_find_vqs() users to virtio_find_vqs_info()
2024-07-08 · Jiri Pirko <jiri@resnulli.us> -
DORMANTno replies
[PATCH virtio v3 19/19] virtio: rename virtio_find_vqs_info() to virtio_find_vqs()
2024-07-04 · Jiri Pirko <jiri@resnulli.us> -
STALE758d
[PATCH virtio v3 17/19] virtio: convert the rest virtio_find_vqs() users to virtio_find_vqs_info()
2024-07-04 · Jiri Pirko <jiri@resnulli.us> -
STALE754d
[PATCH virtio v2 19/19] virtio: rename virtio_find_vqs_info() to virtio_find_vqs()
2024-07-04 · Jiri Pirko <jiri@resnulli.us> -
STALE754d
[PATCH virtio v2 17/19] virtio: convert the rest virtio_find_vqs() users to virtio_find_vqs_info()
2024-07-04 · Jiri Pirko <jiri@resnulli.us> -
STALE758d
[PATCH virtio 19/19] virtio: rename virtio_find_vqs_info() to virtio_find_vqs()
2024-07-03 · Jiri Pirko <jiri@resnulli.us> -
STALE758d
[PATCH virtio 17/19] virtio: convert the rest virtio_find_vqs() users to virtio_find_vqs_info()
2024-07-03 · Jiri Pirko <jiri@resnulli.us> -
STALE827d
REVIEWED: 2 (2M) [PATCH v2 22/25] rpmsg: virtio: drop owner assignment
2024-03-31 · Krzysztof Kozlowski <hidden> -
STALE853d
[PATCH 19/22] rpmsg: virtio: drop owner assignment
2024-03-27 · Krzysztof Kozlowski <hidden> -
STALE1748d
LANDED [PATCH RFC] virtio: wrap config->reset calls
2021-10-13 · "Michael S. Tsirkin" <mst@redhat.com> -
STALE2140d
REVIEWED: 2 (2M) [PATCH v7 2/3] rpmsg: move common structures and defines to headers
2020-09-10 · Guennadi Liakhovetski <hidden> -
STALE2129d
[PATCH v6 2/4] rpmsg: move common structures and defines to headers
2020-09-01 · Guennadi Liakhovetski <hidden> -
STALE2144d
[PATCH v5 2/4] rpmsg: move common structures and defines to headers
2020-08-26 · Guennadi Liakhovetski <hidden> -
STALE2167d
[PATCH v4 2/4] rpmsg: move common structures and defines to headers
2020-07-22 · Guennadi Liakhovetski <hidden> -
STALE2143d
[RFC PATCH 08/22] rpmsg: virtio_rpmsg_bus: Disable receive virtqueue callback when reading messages
2020-07-02 · Kishon Vijay Abraham I <hidden> -
STALE2143d
[RFC PATCH 15/22] samples/rpmsg: Setup delayed work to send message
2020-07-02 · Kishon Vijay Abraham I <hidden> -
STALE2143d
[RFC PATCH 16/22] samples/rpmsg: Wait for address to be bound to rpdev for sending message
2020-07-02 · Kishon Vijay Abraham I <hidden> -
STALE2143d
[RFC PATCH 14/22] rpmsg: Add VHOST based remote processor messaging bus
2020-07-02 · Kishon Vijay Abraham I <hidden> -
STALE2143d
[RFC PATCH 13/22] rpmsg: virtio_rpmsg_bus: Use virtio_alloc_buffer() and virtio_free_buffer()
2020-07-02 · Kishon Vijay Abraham I <hidden> -
STALE2143d
[RFC PATCH 11/22] rpmsg: virtio_rpmsg_bus: Move generic rpmsg structure to rpmsg_internal.h
2020-07-02 · Kishon Vijay Abraham I <hidden> -
STALE2143d
[RFC PATCH 10/22] rpmsg: virtio_rpmsg_bus: Add Address Service Notification support
2020-07-02 · Kishon Vijay Abraham I <hidden> -
STALE2143d
[RFC PATCH 09/22] rpmsg: Introduce configfs entry for configuring rpmsg
2020-07-02 · Kishon Vijay Abraham I <hidden> -
STALE2209d
Re: [PATCH v3 5/5] vhost: add an RPMsg API
2020-06-18 · Vincent Whitchurch <hidden> -
STALE2244d
[RFC 12/12] rpmsg: add a device ID to also bind to the ADSP device
2020-05-29 · Guennadi Liakhovetski <hidden> -
STALE2209d
REVIEWED: 2 (2M) [PATCH v3 3/5] rpmsg: move common structures and defines to headers
2020-05-27 · Guennadi Liakhovetski <hidden> -
STALE2256d
[PATCH v2 3/5] rpmsg: move common structures and defines to headers
2020-05-25 · Guennadi Liakhovetski <hidden>